Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Ford Focus speedo/heater problems

  1. #1
    Join Date
    Mar 2007
    Posts
    3

    Default Ford Focus speedo/heater problems

    Hi all, seems this fault is quite common amongst focus owners. I have a 1999 focus 1.6 manual, and the heater fan only kicks in at settings 3 and 4. I have replaced the resistor behind the glovebox but this has not solved the problem, both old part and new part were tested by an electrician friend of mine and showed working OK. They both showed no signs of burnout, either.

    Also, the speedometer occasionally shows either 0, or flucuates 10mph up and down like its having some sort of fit whilst driving. Obviously, both these faults (particulary the speedo,) are causing some hairy experiences on the road, any suggestions from people who may have solved this fault?

    Many thanks in advance

  2. #2
    Join Date
    Mar 2007
    Posts
    7

    Default

    hey there...

    i have a 51 reg 1.8, and ive had it for a year. had speedo problems for ages, when it was MOTed last month they replaced the lambur (sp) sensor and this fixed it, but now 3 weeks later my orange engine light is back on and my fan/blower has stopped unless it is on 4

    bloody annoying, any ideas!??

  3. #3
    Join Date
    Oct 2006
    Location
    Sussex
    Posts
    1,824

    Default

    For the check engine light you will need to have the vehicle read for fault codes to assist in diagnosing the fault.As for the heater problem if you do a search there is a thread on here where this was discussed.

    HTH

  4. #4
    Join Date
    Feb 2007
    Posts
    33

    Default

    I have just replaced my heater resistor a few weeks back and it solved the problem with the heater only working on the number 4 now they all work

  5. #5
    Join Date
    Mar 2007
    Posts
    7

    Default

    how easy is it to do?

    ive never changed anything on my car...well maybe a lightbulb or two!

  6. #6
    Join Date
    Feb 2007
    Posts
    33

    Default

    It only takes about 15 minutes and you will need a philips screwdriver. I took off the glovebox to get into it, you will see it sitting on the passenger side on the right hand side behind glovebox. The one i took off was blue but the one i put on again was black, cost a tenner from ford depot. Its held in place with one screw at the bottom. Hope all that made sense.
    junior

  7. #7
    Join Date
    Mar 2007
    Posts
    7

    Default

    i'll give it a go sometime, although i may call on you for help!

  8. #8
    Join Date
    Mar 2007
    Posts
    24

    Default

    I had a similar problem with my Clio, the heater blower kept going on and off all the time, I had to remove the blower motor and clean all the connections on the white connector block and the motor itself, and since then it has been perfect.

    Hey Pompeyguy, whereabouts in Pompey are you ? I am in Havant, not far from you.
    Regards
    Sally

  9. #9
    Join Date
    Mar 2007
    Posts
    7

    Default

    im in havant too sally...

    small world

  10. #10
    Join Date
    May 2007
    Posts
    5

    Default

    hi i have a ford focus speedo keeps dropping to 0 and engine is also affected when this happens also stereo goes quiet please help

Similar Threads

  1. Ford Focus Problem (Electrical Fault, I think)
    By Cleo_J in forum Technical and Maintenance Questions
    Replies: 11
    Last Post: 08-07-09, 14:47
  2. Ford Focus Dials
    By hedgie in forum Technical and Maintenance Questions
    Replies: 4
    Last Post: 08-11-08, 13:38
  3. At a loss with Ford Focus trouble
    By MasaM in forum Technical and Maintenance Questions
    Replies: 4
    Last Post: 14-07-07, 17:23
  4. ford focus tdci smoking lots
    By strangerover in forum Technical and Maintenance Questions
    Replies: 0
    Last Post: 26-03-07, 17:37
  5. Ford Focus 1.8 Cold Starting Problems
    By marko in forum Technical and Maintenance Questions
    Replies: 4
    Last Post: 16-02-07, 13:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •