Results 1 to 8 of 8

Thread: Nissan X trail Heating fan not working

  1. #1
    Join Date
    Apr 2008
    Posts
    3

    Smile Nissan X trail Heating fan not working

    I have an 02 reg Nissan XTrail 2.0L Sport. It has done 42,000 miles. The heating fan stopped working temporarily then started working again, recently (about 2-3 weeks ago) it stopped working altogether. The unit for changing where the air comes out, (ie foof well, demist, face) works, just the fan is not working. I have checked the fuses for the blower these are both fine. Does any one know what is wrong? Can you suggest how it could be sort out?

    Many thanks

  2. #2
    Join Date
    Apr 2007
    Location
    Birkenhead
    Posts
    453

    Default

    A thread has already been started with this question, please keep to 1 thread.

    Does the blower motor have live/earth feeds?

  3. #3
    Join Date
    Apr 2008
    Posts
    73

    Default

    I suspect the fan motor is at fault,possibly by dirty contacts.It is located behind the glove box and is easy to remove.Once removed clean up the contacts and give the fan a good spin round by hand,and it should be ok then.

  4. #4
    Join Date
    Nov 2010
    Posts
    1

    Default

    Quote Originally Posted by steve72 View Post
    I have an 02 reg Nissan XTrail 2.0L Sport. It has done 42,000 miles. The heating fan stopped working temporarily then started working again, recently (about 2-3 weeks ago) it stopped working altogether. The unit for changing where the air comes out, (ie foof well, demist, face) works, just the fan is not working. I have checked the fuses for the blower these are both fine. Does any one know what is wrong? Can you suggest how it could be sort out?

    Many thanks
    I have just fixed one of these with the same problem. If you look up from the passenger footwell - there are two plugs going to the blower housing, its the one nearest to the floor. Next to the plug are 2 phillips screws, remove them and pull the whole thing out.
    I am 99.9% sure that the thermal fuse in there has blown, quite easy to fit a new one. 79p from maplins!! Hope this helps.

  5. #5
    Join Date
    May 2011
    Posts
    1

    Default Thank you

    Thanks for the guideline. I checked my thermal fuse and it was blown. I got fixing cd and I tried to find the problem but could not. It is there but not very clear.

  6. #6
    Join Date
    Feb 2012
    Posts
    2

    Default

    Hi bigbaz
    is the thermal fuse inside the heater matrix, and do i have to drain down water from the system?
    thanks cludgie

  7. #7
    Join Date
    May 2008
    Posts
    8,250

    Default

    No. It is on the blower motor housing as said above.

  8. #8
    Join Date
    Feb 2012
    Posts
    2

    Default nissan xtrail heater

    Thanks bigbaz
    i was looking at horizontal Philips screws to the matrix. found other screws in the vertical same area and rusty connections found cleaned them and working again thanks
    to you cludgie

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •