Results 1 to 8 of 8

Thread: Ford Focus 2005 windscreen wipers and indicators flashing when ignition is turned off

  1. #1
    Join Date
    Oct 2012
    Posts
    4

    Default Ford Focus 2005 windscreen wipers and indicators flashing when ignition is turned off

    Yesterday i drove through heavy rain and when returning to my car last night i had a flat battery, jump started the car and drove home.When i got home i turned off the ignition and the windscreen wipers started, the indicators on the nearside started flashing and the heater came on so i ended up disconnecting the battery. This morning reconnected the battery and the same thing happened drove for 30 mins turned off the ignition and the same thing happened. I am assuming it is water in the fuse box if so will it dry out or do i need to do something else? thanks in advance.

  2. #2
    Join Date
    Aug 2011
    Posts
    2,457

    Default

    It may just be coincidence with the heavy rain, maybe you just need a new battery?

  3. #3
    Join Date
    Oct 2012
    Posts
    4

    Default

    Quote Originally Posted by Dennis W View Post
    It may just be coincidence with the heavy rain, maybe you just need a new battery?
    Hi Dennis i reconnected the battery when i got off the train last night expecting the wipers and indicators to start up....nothing, unlocked doors with remote started car drove home. Took key out of the ignition waited for the wipers again nothing. Left battery connected over night no problems. I reckon it was this massive puddle, nearly a flood , that i went through, just need to find out if its the fuse box or CPU that the water is getting in and then try and seal it. Any ideas?

  4. #4
    Join Date
    Aug 2011
    Posts
    2,457

    Default

    How deep was the rain water on the road? Do you think water has got into the fuse box under the bonnet in the engine compartment?

  5. #5
    Join Date
    Oct 2012
    Posts
    4

    Default

    Don't know how deep it was as it was 5am at the end of a country lane i hit it and caused a huge wave, when i looked under the bonnet later you could see the engine was still pretty wet, i was thinking more of the fuse box in the passenger foot well as i have heard there is sometimes a leak from the engine compartment into here, to be honest i have had alot of trouble with this car since new!!!

  6. #6
    Join Date
    May 2008
    Posts
    8,273

    Default

    You may be on the right lines with the fuse box inside the car. Ford call the part a GEM (general electronic module) and most of the systems in the car pass through this part like the lights, wipers, door locking etc etc. Sounds like it has dried itself out now.

  7. #7
    Join Date
    Apr 2012
    Posts
    2,762

    Default

    Remember that the RAC won't come out if you bugger it going through a flood.

  8. #8
    Join Date
    Oct 2012
    Posts
    4

    Default

    yeah i know this was a bloodt great puddle but hopefully sorted now thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •