Results 1 to 4 of 4

Thread: Help!!!

  1. #1
    Join Date
    Oct 2012
    Posts
    2

    Default Help!!!

    Right im new to all this forum stuff so be nice lol,

    I have a 1.9cdti sri 150 vectra on a 54 plate and have a problem with it and have no idea what it is so would like to pick a few brains!.
    Problem is,car hangs back,almost like its going to stall,and then picks up again,sometimes kicks a big black cloud out the rear when it does it usually does this at lower revs and speeds but is becoming more often all over the range,but just recently it has started to loose all power and completely cut out on me even from 60mph! Turns on straight after though and carries on like nothings happened
    I was told this was an egr valve problem,so had it changed,low and behold problem persists.Becoming a right royal pain up the backside!

    Any advice/help would be much appreciated
    Thanks!

  2. #2
    Join Date
    May 2008
    Posts
    7,921

    Default

    When the EGR valve was replaced was the air flap and housing and inlet manifold dismantled and also cleaned? If not, a waste of money I'm afraid.
    It usually isn't the valve at fault but carbon blockage causing this type of fault. The blockage throws out the airflow sensor and the readings become wrong.

  3. #3
    Join Date
    Oct 2012
    Posts
    2

    Default

    im assuming so,i kno the egr valve is a fairly quick/straight forward job,when it was done it was in for around 3-4hours.Egr wouldn't take that long surely?

  4. #4
    Join Date
    May 2008
    Posts
    7,921

    Default

    You need to ask some questions I think!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •