Results 1 to 7 of 7

Thread: Ford Focus O2 Sensor/CAT and Code P0420

  1. #1
    Join Date
    Oct 2008
    Posts
    42

    Default Ford Focus O2 Sensor/CAT and Code P0420

    Hi

    Ford Focus 2003 Petrol 1.6

    My car has been running rough for the best part of a year!! Finally it has thrown code P0420.

    I have been told that this could relate to either a O2 Sensor or the CAT.

    Would I not have another code apart from the P0420 if it was the O2 Sensor as code P0420 is Catalyst System Efficiency Below Threshold (Bank 1) which I would suggest is the CAT at fault?

    Also I might be wrong but the car seems to run better now the code has been thrown up which I find very odd?

    Any thoughts people?

    Many Thanks

  2. #2
    Join Date
    May 2008
    Posts
    10,545

    Default

    Yes its the cat but in live data you can confirm this by watching the second sensor. It should NOT switch up and down like the front one. If it does then it confirms the cat is dead.

  3. #3
    Join Date
    Oct 2008
    Posts
    42

    Default

    Hi

    Thanks the 2nd sensor was reading a steady 1.275V last time I checked so think the cat. Can you (or anybody reading this)recommend anybody in the South Yorkshire area that stock and fit them at a good price please?

  4. #4
    Join Date
    May 2008
    Posts
    10,545

    Default

    The second sensor should be a steady 0.6v or similar. !.275v is way too high. If you can get it scanned again check for this value with engine hot, cat hot (run at 3,000rpm for good 3 minutes) and hold revs steady about 2,800rpm. If the reading is still way high, find the short term fuel trim - S.T.F.T. - in the menu and ensure it stays between +5% to -5%. If it doesn't then the main fault may be elsewhere eg airflow sensor.

  5. #5
    Join Date
    Oct 2008
    Posts
    42

    Default

    Ok I will get some new live readings and report back

  6. #6
    Join Date
    Feb 2016
    Posts
    1

    Default

    Hi, Did you ever resolve this? I've got the same problem and found this old thread. I've got code P0420, pre-cat o2 sensor voltage going up and down within expected limits and after cat o2 sensor reading 1.275v. Any help would be appreciated.

  7. #7
    Join Date
    May 2008
    Posts
    10,545

    Default

    P0420 - cat efficiency below threshold. If at any time the car has had a misfire then it will have damaged the cat and results in this code. The ssenor reading is too high and is either because there is incorrect gas flow due to a partially blocked cat, the sensor has failed or there is a wiring fault. Try revving the engine quite hard on and off the pedal. Lifting off should make the sensor move down. If it does then its probably working okay.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Follow RAC:

Sales enquiries:

0330 159 1111

03 numbers are charged at national call rates and included in inclusive minute plans from landlines and mobiles. Calls may be monitored and/or recorded