Results 1 to 4 of 4

Thread: Ford Focus 1.6 - Instrument cluster lights not working

  1. #1
    Join Date
    Sep 2009
    Posts
    1

    Default Ford Focus 1.6 - Instrument cluster lights not working

    The lights on my Ford Focus instrument cluster faded out and died today. The clock and speedometer etc are all still working, however the lights to light it all up isn't working. When the car's headlights are on, this seems to exacerbate the problem. Also the light on the car stereo flashes if the headlights are on. I don't know much about these things but don't want to get overcharged by a garage if it is something as simple as a bulb or loose connection. Any help is much appreciated - thank you

  2. #2
    Join Date
    May 2008
    Posts
    8,454

    Default

    There is a thread on here that has been viewed over 104,000 times on this topic.
    Type Ford Focus dash into the search box.

  3. #3
    Join Date
    Mar 2012
    Posts
    1

    Default

    104,000 times? Really where is this post? Your search just brings up all sorts of useless information that we have to wade through. The funny thing is that this post is the one with the most views and yet it just has a snotty response. Why not just answer the question or give a link to the correct answer?

  4. #4
    Join Date
    May 2008
    Posts
    8,454

    Default

    Can't you read? In the Technical and Maintenance section that this thread is in, at the very top of the list of threads is one called FORD FOCUS DASH ELECTRICAL FAULT. It has had 415 replies and 290,908 views. If you can be bothered looking at it that will take the views up to 290,909. Amazingly difficult isn't it? Oh, and would you like us to wipe your botty seeing as everything is too much trouble for you, like reading?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •