Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Nissan Micra Engine Warning light

  1. #1
    Join Date
    Aug 2008
    Posts
    6

    Question Nissan Micra Engine Warning light

    I have recently had my Micra serviced & MOT'd, but my engine warning light is till coming on. I have had both Lambda Sensors replaced & the garage has checked the management system. Can anyone assist with what else might be causing this?

    Nissan Micra 1.0 2001
    Last edited by GerryB; 02-08-08 at 12:26. Reason: Forgot to enter make & model.

  2. #2
    Join Date
    May 2007
    Posts
    5,240

    Default

    You need to have it checked with a code reader. If it is coming up with a cam sensor fault then it is probably a stretched timing chain.

  3. #3
    Join Date
    Aug 2008
    Posts
    6

    Smile

    Many thanks, will have it looked at.
    Gerry

  4. #4
    Join Date
    Jan 2010
    Posts
    10

    Default

    GerryB ... was your problem solved? if yes how?

  5. #5
    Join Date
    Aug 2008
    Posts
    6

    Smile Nissan Micra Engine Warning Light

    No it has not been solved as yet. Although I have been told it could either be the timing belt or just a fault in the diagnostics. Not prepared to take that chance, so am taking it in for another check up in the next week or so.

    Do you have any alternative suggestions?

    GerryB

  6. #6
    Join Date
    Jan 2010
    Posts
    10

    Default

    I asked you because I have the same problem.
    A friend of mine told me that it could be because I removed the battery and the car computer need to be reseted, since I am not seeing any difference in the performance.

    I will let you know if i solve the problem ....

  7. #7
    Join Date
    Aug 2008
    Posts
    6

    Default Nissan Micra Engine Warning Light

    That would be great thanks. My engine warning light has been on and off now for over a year and I've had no problems. Also, if I find the solution in the next few weeks will let you know.

    GerryB

  8. #8
    Join Date
    Jan 2010
    Posts
    10

    Default

    good luck mate ..... have you noted any degradation in the car performance?

  9. #9
    Join Date
    May 2007
    Posts
    5,240

    Default

    Might be worth you looking at this http://static.forum.rac.co.uk/showthread.php?t=9726As it seems to be a common fault.

  10. #10
    Join Date
    Aug 2008
    Posts
    6

    Default

    I thought it was a bit sluggish at first, but maybe I've just got used to it, due to the length of the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •