Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: nissan micra problems

  1. #1
    Join Date
    Mar 2008
    Posts
    6

    Exclamation nissan micra problems

    Nissan Micra Reg 1999 1.3 3 door hatchback Petrol 5 speed manual

    I had a problem with car not starting - called RAC and they advised changing the distributor. Did this and car started but running on only 2 pistons. So changed spark plugs and HT leads - checked and cleaned all earth connections etc but still runs poorly on 2 or 3 pistons. Changed fuel injectors on pistons 1 and 4 slight improvement then back to 2 pistons !

    Any ideas as my mechanic is now completely baffled ??

  2. #2
    Join Date
    Oct 2006
    Location
    Sussex
    Posts
    1,824

    Default

    Have you checked the spark and fuel injector pulse on each cylinder and aslo carried out a compression test??? Another possibility could be the throttle body see this thread
    Last edited by Sussex Patrol; 13-03-08 at 07:19.

  3. #3
    Join Date
    Mar 2008
    Posts
    6

    Cool nissan micra problems (markus)

    To Sussex Patrol ( Senior member)

    Thanks for getting back to me - there seems to be pulses and sparks on all four up to the fuel injection, and on to the spark plugs but the mechanic is checking the cylinders today via a compression test. I have also told him your suggestion re : throttle body so he will also test that for me and hopefully we'll reach a solution ! He can canabalise an old Nissan Micra to check the 'computer' as he puts it and the other parts so I don't spend too much !

    Thanks for your help again,

    Best,

    Markus

  4. #4
    Join Date
    Mar 2008
    Posts
    6

    Angry Nissan micra problems from Markus

    Nissan Micra Reg 1999 1.3 3 door hatchback Petrol 5 speed manual
    Further to my last 2 entries (see below) I have spoken with my mechanic who has tried a new throttle body and changing the computer but with no change - he also swapped spark plugs on the non-firing cylinders and now the car won't start at all ! Oh he also tested the compression and all 4 cylinders seem to be OK - I suggested we go back to basics and try new spark plugs and maybe distrubutor in case those supplied were faulty - otherwise we are stumped - any ideas ??


    Thanks everyone,

    Markus




    I had a problem with car not starting - called RAC and they advised changing the distributor. Did this and car started but running on only 2 pistons. So changed spark plugs and HT leads - checked and cleaned all earth connections etc but still runs poorly on 2 or 3 pistons. Changed fuel injectors on pistons 1 and 4 slight improvement then back to 2 pistons !

    Any ideas as my mechanic is now completely baffled ??

    Thanks for getting back to me - there seems to be pulses and sparks on all four up to the fuel injection, and on to the spark plugs but the mechanic is checking the cylinders today via a compression test. I have also told him your suggestion re : throttle body so he will also test that for me and hopefully we'll reach a solution ! He can canabalise an old Nissan Micra to check the 'computer' as he puts it and the other parts so I don't spend too much !

  5. #5
    Join Date
    Apr 2007
    Location
    Birkenhead
    Posts
    453

    Default

    If he has changed the ECU (computer) the nthe keys will probably need recoding, is the yellow engine light flashing??

  6. #6
    Join Date
    Oct 2006
    Location
    Sussex
    Posts
    1,824

    Default

    I have asked admin to merge this with original thread as it makes sense to keep all the info in one place.

  7. #7
    Join Date
    Aug 2006
    Posts
    864

    Default

    threads merged

  8. #8
    Join Date
    Oct 2006
    Location
    Sussex
    Posts
    1,824

    Default

    Cheers Mike. As Mersey Patrol says is the management light flashing-possibly immobilized? Also have you got spark/injector pulse/fuel pump run?

  9. #9
    Join Date
    Mar 2008
    Posts
    6

    Angry Nissan micra problems (markus)

    Someone mentions nthe keys - what are these ? Or is it a spelling error ??
    And I am not sure what exactly is meant by "Also have you got spark/injector pulse/fuel pump run?"

    The spark plugs are working and there is definitely a pulse from the fuel injectors - but the cylinders just don't seem to be getting the message !
    Help ! It's driving us NUTS !!

    Best,

    Markus

  10. #10
    Join Date
    Apr 2007
    Location
    Birkenhead
    Posts
    453

    Default

    spelling error.

    If the computer has been replaced, then the ignition keys will need reprogramming or the immobiliser will remain active, not allowing the car to start.

    When you insert the key into the ignition and try to start, is there a yellow light flashing on the dash?

    If it doesnt then thats ok. You then need to check that you have got 1. spark at the plugs, 2. Is the fuel pump sending fuel to the engine and 3. are the injectors getting a pulse from the computer telling them when to open.

    When you turn over does it try and start?
    Last edited by MerseyPatrol; 15-03-08 at 01:00. Reason: spelling (again)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •