Results 1 to 5 of 5

Thread: Clio Heater

  1. #1
    Join Date
    Oct 2007
    Posts
    2

    Default Clio Heater

    Hi,

    I have a renault clio 1.2 1994/1995. A year ago the heater stopped giving any heat, still blowing out fine but no heat apart from minimal on the lowest blowing setting. I had a new heating matrix fitted and had heat for a couple of days and then it stopped. I had it all investigated last week and he put some solvent through the system to flush it out but this didn't work. He now says i need a new heater matrix...i wouldn't mind but it didn't work last time what's to say it will work this time?! Anyone got any advice or tricks to fix this without another new matrix? Or could tell me why it is doing this?!

    Any help much appreciated.

    Thanks

  2. #2
    Join Date
    Oct 2006
    Location
    Sussex
    Posts
    1,824

    Default

    Firstly you need to establish where the problem lies.I would suggest running the vehicle up to temperature and feeling the rubber hoses to see if they all warm up,paying attention to the two hoses that pass through the bulkhead.
    If the two hoses that go to the heater matrix are getting warm,it could point to a flow problem with the matrix or even a problem with the heater controls.
    If the pipes that feed the matrix don't get warm then that would indicate a flow problem with the cooling system and things to check would be thermostat operatrion and are there any cold spots in the radiator.
    Out of interest what is the condition of the coolant in regards to colour? is it a brown sludge colour?

  3. #3
    Join Date
    Oct 2007
    Posts
    2

    Default

    Thank you very much for the advice...unfortunately i haven't got a clue about any of that! I'll see if I can get my bro in law to check those things for me!!!!

    Thanks!

  4. #4
    Join Date
    Mar 2008
    Posts
    1

    Default renualt clio heating

    I have the same problem with a renault clio 1992. Have been advised it needs a new heating matrix. Is it worth trying a solvent first. What solvent is appropraite?

  5. #5
    Join Date
    Mar 2010
    Posts
    2

    Default

    I also have a clio (1995 M, 1.2 RL) with heating problems. I was told i would need a new heating matrix, but I think I should ask about flushing the system and testing the thermostat first, since it seems this is a fairly frequent problem. I checked the cables from the controls myself, but that's about as far as my knowledge goes!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •