Results 1 to 4 of 4

Thread: Ford Mondeo 1.9 (2006) petrol cruise control problem

  1. #1
    Join Date
    Aug 2014
    Posts
    2

    Default Ford Mondeo 1.9 (2006) petrol cruise control problem

    Hi
    The vehicle cruise control does not switch on at over 25mph as it should. The local garage checked for fault codes and none were present. All fuses are intact. The cruise control symbol does appear briefly on the dash when the ignition is switched on - but it does not appear if an attempt is made to switch the cc on. Does anyone have any idea what the problem might be?
    Any help would be much appreciated
    bluerhino

  2. #2
    Join Date
    Apr 2012
    Posts
    2,889

    Default

    My guess would be either a faulty switch or a fault in the ECU. Either way it is likely to be an expensive fault to find and repair.

  3. #3
    Join Date
    May 2008
    Posts
    8,442

    Default

    Check that your brake lights are working correctly and the bulbs are good. Part of the cruise system is controlled by the brake switch. The garage should have checked in the engine ECU and the ABS system to see if the switch was working properly. Did they also check the other ECUs on the car such as the body control module (Ford call it the GEM) and the instrument cluster which may have stored faults?

  4. #4
    Join Date
    Aug 2014
    Posts
    2

    Default bluerhino

    Thanks for the help - will look into your suggestions. Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •