Results 1 to 4 of 4

Thread: Astra problems

  1. #1
    Join Date
    May 2012
    Posts
    1

    Default Astra problems

    Hey there this is my first time on here so giving it a shot. Right where to start, I have a 53 Astra 1.7cdti. It's been a great servant up until a week ago when it simply cut out parked at the lights. Rac came to my rescue and played under the bonnet for a while an it started again, diagnostics was "possible fuel pump". 2 days later this time I wasn't parked at lights with the engine running I was at home , the car had been parked overnight tried in morning didn't start, went to work came home tried again, started haha. Next day only this time car got me to town no problem done my shopping returned to car tried to start and no joy , rac came diagnostics was cam sensor failure . I replaced cam sensor an put fuel in and guess what?? it failed again today after driving for 5 mins then stopping for a paper.. The oil cap is nice an black , no white or brown gooey stuff so ruling head gasket out . . Please can someone help

  2. #2
    Join Date
    May 2008
    Posts
    8,201

    Default

    May be the control unit for the fuel pump, which is a metal box mounted beside the pump down the back of the engine on the driver's side, as these do suffer from failure of the soldered joints inside. The box is held by 4 10mm bolts so easy to remove. Then cut through the sealant and open the box up and you can see the printed circuit. The larger soldered points may be dry and a re-solder may work.
    This should only be done by a competent auto electrician or you could seriously damage the unit.
    A proper diagnostic check should first be carried out, forget the RAC, their diagnostic tools cannot do the job properly (never changed a can sensor on one of these, perhaps he said crank sensor which could cause the problem), A good recommended garage such as a Bosch Service Centre, a diesel specialist or auto electrical garage should sort this for you.

  3. #3
    Join Date
    Aug 2010
    Posts
    817

    Default

    I believe if my memory serves me correct the fault code is usually cam rotor failure can't rember the code but as hometune mentions the ecu can be resoldered I have done several roadside and the joints that are dry are easily identified



    Miss breakdown

  4. #4
    Join Date
    May 2008
    Posts
    8,201

    Default

    The cam rotor and the cam sensor are 2 different items. The sensor mounts on the engine and the rotor is inside the fuel pump. If you resolder the EDU (the box of electrics) and the problem is still there then likely to be the pump itself.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •