Results 1 to 9 of 9

Thread: Citroen C3 EGR Valve and engine diagnositcs help!!!!

  1. #1
    Join Date
    Apr 2012
    Posts
    15

    Default Citroen C3 EGR Valve and engine diagnositcs help!!!!

    Hi all,

    I've got a 2004 Citroen C3 SX 1.4 HDi 92Bhp and had the engine light come on recently so took it in to the garage for diagnositcs.

    Originally it returned four codes but they were not sure is these were old or new codes so reset the computer and told me to come back when the light came back on to see what was there. This happened so duly went back to the garage.

    They returned the following codes:

    P0401

    P0400

    P1351

    There advice at this stage was that it must be the EGR valve and it would need replacing. I know these models can suffer from a sticky EGR value so I asked to have it cleaned and they said this wouldn't be worth it and it would be best to replace the unit. They also said that 'we can't confirm this will fix the problem so there might be more work needed after this' - not inspiring confidence at this point!

    I should say that the light is intermittent - some days it's there others it's not. when it is there it's a solid light and accompanied by three beeps to let me know there's a problem.

    I also have the following to note on the car (which may have nothing to do with this issue but who knows?) ... When I reverse the car I get a combination of six beeps (standard I believe when selecting reverse) but sometime this gives me three short beeps and then starts to sound like reversing sensors until I get the flat line noise - considering I don't have parking sensors this really confuses me!!!

    There is also a metallic rattling when the engine warms up which I think is coming from the exhaust (loose fitting perhaps?) from low revs up to about 1500rpm in the lower gears and then comes back after about 3/3500 rpm.

    I don't just want to throw 200 at the problem on the garages say so when it might not do any good at all. Can anyone help with ideas or suggestions as to how to fault find the real issue and not just replace parts?

    I've had the car about two months and it's covered 55k. Has a warranty with Warranty Wise but they don't want to know.

    Thanks in advance,

    Talkingheads

  2. #2
    Join Date
    Apr 2009
    Posts
    6,379

    Default

    If you bought it from a dealer, tell him to resolve the issues, the dealer legally has to give a six months warranty. The other one (3 month) is just worthless paper.

  3. #3
    Join Date
    Apr 2012
    Posts
    15

    Default

    Is this right? other places are saying three months not six. I did buy it from a second hand dealer. I'll get back in touch with him.
    Last edited by Talkingheads; 21-04-12 at 16:42.

  4. #4
    Join Date
    Apr 2009
    Posts
    6,379

    Default

    Oh dear, I think you need a garage that understands the diagnostics. Keep an eye on the forum; there are other posters who are likely to know the engine.

  5. #5
    Join Date
    May 2008
    Posts
    7,944

    Default

    P0400 EGR valve flow malfunction.
    P0401 EGR valve insufficient flow detected
    P1351 glow plug fault

    If you use the car for short town journeys there is a good chance the EGR valve will be clogged up along with the associated pipes and possibly the inlet manifold as well. During the diagnostics the garage should have checked its operation on their computer in the live data function. It is quite easy to remove the valve and clean it all out on this engine so why they are reluctant, who knows? Maybe find another that will do this for you. It will cost you some labour time but if it works then you have saved yourself a fortune. You should also check the vacuum pies around the engine for any leaks as a loss will cause this symptom too. Also ensure all turbo pipes are in good condition with no splits. The exhaust rattle should be investigated in case it is inside and causing a blockage which will also give you these codes.
    One or more of your glow plugs is faulty giving P1351.

    Sale of Goods Act says 6 months, not 3.

  6. #6
    Join Date
    Apr 2012
    Posts
    15

    Default

    Hi Hometune,

    Thanks very much for the helpful reply - definitely something I can use! I think the car has been used a lot for shorter journeys in its former life but I tend to use it for commuting (40mile each way journey).

    I'm going on a long road trip soon so I was going to treat the car and put it through a full service so will probably ask the garage to look at cleaning up the EGR, wastegate, inlet manifold and changing the glow plugs for a new set - anything else I should consider while they are in there??? if this doesn't fix the problem is it possible that the MAF could cause the 401 fault?

    Many thanks

  7. #7
    Join Date
    May 2008
    Posts
    7,944

    Default

    No the MAF will not trigger this code. There are products available that can be sprayed into the induction side of the engine to help clean the carbon without dismantling. Maybe ask the garage for a quote?

  8. #8
    Join Date
    Apr 2012
    Posts
    15

    Default

    As a quick update I've had a full service done on the car and I asked the garage (recommended at honestjohn) to clean the wastegate, inlet manifold and EGR valve. They said the EGR was pretty clean (despite the insistence of the first garage this would be coked up because all C3's run very dirty) but I'm chasing for feedback on the manifold and wastegate to ensure these were cleaned. They also tested the glow plugs and found two faulty so replaced these. Since then the light has come back on and disappeared within one trip and is now back on after a few days break.

    I'm going to ask the garage to run another code read but there are no symptoms that I can tell from driving. Could this just be a faulty sensor or something much worse (Have I bought a turkey???)

  9. #9
    Join Date
    May 2008
    Posts
    7,944

    Default

    Yes get the fault code(s) and take it from there. Maybe the EGR valve is faulty or somewhere else in the engine is blocking up a bit. The garage should be able to find this fairly quickly.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •