Results 1 to 3 of 3

Thread: Vauxhall Astra over rev problem.

  1. #1
    Join Date
    Dec 2010
    Posts
    3

    Default Vauxhall Astra over rev problem.

    Hi
    I'm hoping someone might be able to shed some light on this problem because I'm at a loss.
    I've got a Vauxhall Astra 1.4 16v Z14XE thats got an over rev problem. This only happens when changing up through the gears. If I change gear at say 2000 revs, when I press the cluch and let my foot off the accelerator, the revs will keep on climbing by around another 500 revs before dropping again.This only happens when driving, if I'm stationary and rev the car the problem isn't there.The engine management light never comes on and the car runs perfectly other than this problem. So far I have replaced the throttle body and MAP sensor. I have also tested the air temp sensor with a multi-meter and hairdryer for operation and its working fine. Ive also checked for air leaks and can't find any. If anyone has an idea what this could be I would be most grateful for your ideas.
    Thanks
    Sparks

  2. #2
    Join Date
    May 2008
    Posts
    8,213

    Default

    If this was a Ford Focus it would be the speed sensor in the gearbox. Maybe try disconnecting it and trying it? Its in the gearbox unless you have ABS. It may bring the engine management light on.

  3. #3
    Join Date
    Dec 2010
    Posts
    3

    Default

    Thanks for your input. I'll give it a go and see what happens. Sparks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •